Using Apple® AirPrint® with Xerox® AltaLink® Multifunction Printers
User Guide
Contents

What is AirPrint®? ................................................................................................................................. 1
New AirPrint Capabilities in Xerox® AltaLink® Multifunction Printers (MFPs) ........................................... 1
Existing AirPrint Capabilities .................................................................................................................. 1
AltaLink® AirPrint® Capabilities versus Client Support Table ............................................................... 2

What are the requirements for using AirPrint®? ....................................................................................... 3
  Network Requirements ............................................................................................................................ 3
  Xerox® AltaLink Requirements .............................................................................................................. 3
  Apple Device Requirements .................................................................................................................. 3
    AirPrint iOS Requirements ................................................................................................................ 3
    AirPrint macOS Requirements ........................................................................................................... 3
    Applications that Support AirPrint ..................................................................................................... 3

How is AirPrint® enabled and configured on a Xerox® AltaLink® device? ................................................ 4

New AirPrint® Capabilities in AltaLink® ................................................................................................. 6
  Secure Print/PIN Printing ...................................................................................................................... 6
    Description ......................................................................................................................................... 6
    Requirements ..................................................................................................................................... 6
    Limitations ......................................................................................................................................... 6
    Client Support ................................................................................................................................... 6
    Workflow ............................................................................................................................................ 7
  Scanning via AirPrint® .......................................................................................................................... 11
    Description ......................................................................................................................................... 11
    Requirements ..................................................................................................................................... 11
    Limitations ......................................................................................................................................... 12
    Client Support ................................................................................................................................... 12
    Workflow ............................................................................................................................................ 13
  AirPrint® via IPP USB ............................................................................................................................ 18
    Description ......................................................................................................................................... 18
    Requirements ..................................................................................................................................... 18
    Client Support ................................................................................................................................... 19
    Workflow ............................................................................................................................................ 19
Enhanced Security .................................................................................................................. 21
Description .......................................................................................................................... 21
Expanded Accounting Workflows with Apple Clients .............................................................. 21
AltaLink AirPrint Capabilities versus Client Support Table .................................................... 21
Directly Configure AltaLink® Device Accounting User IDs to Match Apple Client Values .......... 23
Description .......................................................................................................................... 23
Requirements ...................................................................................................................... 23
Limitations ........................................................................................................................... 23
Client Support ...................................................................................................................... 23
Workflow .............................................................................................................................. 23
Enable IPP Authentication with Accounting ............................................................................ 26
Description .......................................................................................................................... 26
Requirements ...................................................................................................................... 27
Limitations ........................................................................................................................... 27
Client Support ...................................................................................................................... 27
Workflow .............................................................................................................................. 27
Existing AirPrint® Capabilities ............................................................................................... 32
Printing .................................................................................................................................. 32
Description .......................................................................................................................... 32
Requirements ...................................................................................................................... 32
Limitations ........................................................................................................................... 33
Client Support ...................................................................................................................... 33
Workflow .............................................................................................................................. 33
Outgoing Facsimile (FaxOut via IPP) ..................................................................................... 41
Description .......................................................................................................................... 41
Requirements ...................................................................................................................... 41
Limitations ........................................................................................................................... 41
Client Support ...................................................................................................................... 41
Workflow .............................................................................................................................. 42
Accounting Workflows via IPP Exceptions ............................................................................. 46
Description .......................................................................................................................... 46
Requirements ...................................................................................................................... 46
Client Support ...................................................................................................................... 46
XSA Workflow ...................................................................................................................... 46
Print Authentication Support ................................................................................................. 49
Description .......................................................................................................................... 49
Using Apple® AirPrint® with Xerox® AltaLink® Multifunction Printers
What is AirPrint®?

AirPrint is Apple® driverless printing/job submission technology. It enables Apple devices, including the iPhone®, iPad®, iPod touch®, and even macOS®, to print and fax to AirPrint-enabled devices without installing drivers or downloading software. AirPrint uses well-established, familiar technologies already in use today including Bonjour®, IPP (Internet Printing Protocol), PDF and JPEG.

New AirPrint Capabilities in Xerox® AltaLink® Multifunction Printers (MFPs)

The latest AirPrint support on AltaLink devices includes:

- Secure Print/PIN printing: macOS clients support this security feature
- Scanning via AirPrint: Image scanning to macOS clients
- AirPrint via IPP USB: macOS clients can support AirPrint capabilities (Print/Scan/Fax) via a USB print port
- Enhanced Security enabling seamless integration with high security Apple clients
- Expanded accounting workflows with latest Apple clients

See below for additional information on these new capabilities.

Existing AirPrint Capabilities

- Driverless printing from iOS and macOS clients.
- Outgoing facsimile: macOS clients can utilize AirPrint to support outgoing facsimile from an embedded fax-enabled AltaLink device.
- Print Accounting workflows via IPP exceptions: Optionally track AirPrint/IPP submitted print jobs against specific IPP accounting exceptions on the AltaLink device.
- Print/Outgoing Fax Authentication support: Optionally configure the AltaLink device to require AirPrint/IPP clients to authenticate via HTTP Basic Authentication before submitting a Print/Outgoing Fax job.
- Identify Printer capability: Some AirPrint clients can Identify the Printer to help end users find the AltaLink device.

See below for additional information on these capabilities.
**AltaLink® AirPrint® Capabilities versus Client Support Table**

AirPrint functionality relies on both the AirPrint Clients/Apps and the Xerox® AltaLink device. Utilizing the latest client versions enables the broadest set of functionality. The table below is meant as a reference to help determine which AirPrint capabilities are available with AltaLink and the latest Apple clients.

<table>
<thead>
<tr>
<th>AirPrint Capabilities</th>
<th>Clients</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>iOS Clients</td>
<td>macOS® Clients</td>
</tr>
<tr>
<td>Scan</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Authentication</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>FaxOut (Outgoing Fax)</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Print</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>• Identify Printer</td>
<td>Yes*</td>
<td>Yes</td>
</tr>
<tr>
<td>• Authentication</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>• Accounting</td>
<td>Yes*</td>
<td>Yes*</td>
</tr>
<tr>
<td>• PIN Printing</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>• Finishing</td>
<td>Yes*</td>
<td>Yes*</td>
</tr>
<tr>
<td>IPP USB</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>• FaxOut</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>• Print</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>• Scan</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Security Enhancements</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

(enhanced certificate security, enhanced encryption strength security)

*Applicable on iOS starting in iOS 10

*Apple devices implemented accounting differently than Xerox® AltaLink devices. For AltaLink devices, use Accounting IPP Exceptions.

*Limited finishing capabilities through IPP includes: bind, fold, punch, staple and stitch

Latest client versions as of this writing: iOS 10.1.1 and macOS 10.12.1 Sierra
What are the requirements for using AirPrint®?

Network Requirements

AirPrint requires that devices are discoverable via the Bonjour® protocol. Bonjour is Multicast DNS (mDNS) based. In some networks, mDNS traffic is not allowed to be passed across subnets. In these instances, a device will only be discoverable if the Apple device and the AirPrint-capable AltaLink® device are on the same subnet.

Xerox® AltaLink Requirements

AltaLink can be configured for wired or wireless networking. There is no requirement for AltaLink to be wirelessly enabled. The Apple® iOS device will be using wireless. For AirPrint to work with a wired printer, the wired and wireless network segments need to be bridged and allow mDNS traffic to be routed between them.

For outgoing facsimile support through AirPrint, the AltaLink device must have at least one embedded fax line configured for at least the ‘Send’ functionality.

For AirPrint support via IPP USB, AltaLink must have the Type B USB port configured for Direct Printing.

Apple Device Requirements

Utilizing the latest client versions enables the broadest set of functionality.

AIRPRINT IOS REQUIREMENTS

To use AirPrint, you will need one of the following devices with the latest version of iOS:

- iPad® (all models)
- iPhone® (3GS or later)
- iPod touch® (third generation or later)

AIRPRINT MACOS REQUIREMENTS

- macOS® 10.6 and above

See www.apple.com for the latest operating systems that support AirPrint.

APPLICATIONS THAT SUPPORT AIRPRINT

You can print from any iOS application that supports the Print function. For example: iBooks®, Mail, iPhoto® and Safari®. Other applications are available from the App Store® and may also offer this feature.
How is AirPrint® enabled and configured on a Xerox® AltaLink® device?

AirPrint is enabled on AltaLink devices by default. If, however, AirPrint has been disabled, an administrator can re-enable it following the steps below:

1. You will need the device IP address or DNS name to access the AirPrint configuration Web interface from your browser. You can find the IP address at the device UI screen. From the front panel in the device, go to the Device App and select the About button. The IP address will be shown on this page or you can select Informational Pages from within the Device App and select and print the configuration report.

2. Open the AltaLink’s Web interface by entering the IP address of the AltaLink into a Web browser’s address box (http://<IP>). This will open the Web interface.

3. Click on the Properties tab (enter credentials if prompted).

4. Select Connectivity > Setup. This will bring up the Connectivity page in the right frame.

5. Under Mobile Workflows, look for AirPrint.

6. Select Edit on the AirPrint row. This will open the AirPrint configuration page.
7. On the AirPrint page, under Enablement, select the check box for **Allow Printing/Faxing to be initiated From AirPrint Supported Devices**.

**Note:** If FAX is installed and enabled, it will be supported via AirPrint® when Printing is enabled.

**Note:** AirPrint requires IPP and Multicast DNS Registration services. When AirPrint is enabled, these services are automatically enabled.

8. On the AirPrint page, under Enablement, select the check box for **Allow Scanning to be initiated From AirPrint™ (or Mopria) Supported Devices** to enable Scanning via AirPrint.

9. Configure a **Device Name**, **Device Location** and **Geographic Location**. These attributes distinguish the AirPrint printer as seen from the Apple application.

**Note:** If AirPrint settings cannot be found on the AltaLink device’s Web interface, please refer to the “AirPrint Feature Installation Key” section of this document.
New AirPrint® Capabilities in AltaLink®

Secure Print/PIN Printing

DESCRIPTION
The Secure Print/PIN Print feature protects sensitive or private printed data from unauthorized disclosure by only allowing it to be printed when the user is present at the machine to release the job. Secure Print/PIN Print jobs submitted to a device are held. The user must provide a PIN that authorizes the device to print or delete the job.

REQUIREMENTS
Configure the Secure Print Passcode Length on the AltaLink Web page: Properties > Security > Secure Print > Defaults. The default passcode length is 4. The AltaLink device supported range is 4–10. The PIN must be a numeric value.

For AirPrint (and other IPP jobs), the AltaLink device will use the user name provided by the client as the submitter’s user name of the PIN print job.

LIMITATIONS
- The AltaLink device supports Secure Print/PIN values that are numeric values only (no text).
- Current macOS® clients only allow for input of 4-character PINs.
- If a PIN entered at job submission on the client does not conform to the minimum length set at the device, the secure print job shall not be submitted to the device.

CLIENT SUPPORT
- Only supported on macOS clients.
WORKFLOW

1. Configure/Verify the Secure Print Passcode Length on the AltaLink® device is 4.
2. Add an AirPrint® Printer on a macOS® client.
3. Open a file to print on the macOS client.
4. Select Print from the File menu.
5. Select the Xerox® Printer from the list of printers.
6. Configure the desired printer options (i.e., copies, media, layout, finishing, etc.).
7. Configure the PIN Printing option:

8. Enable PIN Printing and enter in a 4-digit numeric PIN.
9. Select Print.

10. On the AltaLink® Local User Interface, select Jobs.

11. The PIN Printing job is held in Secure Jobs.

13. Select the name of the owner of the Secure Print job.

14. Enter in the PIN/Passcode entered when the job was submitted.
15. Select the individual job to release it for printing or select from the other job management options.

16. The job is released for processing.
Scanning via AirPrint®

DESCRIPTION
macOS® clients can utilize AirPrint to support image scanning.

REQUIREMENTS
- Allow Scanning to be initiated from AirPrint Supported Devices must be enabled.
- Navigate to the AltaLink® Web interface: Properties > Connectivity > Setup > AirPrint > Edit.
- Enable Allow Scanning to be initiated from AirPrint (or Mopria®) Supported Devices.

- Optionally configure Authentication for Scanning.
- Select HTTP Basic or HTTP Digest to allow AirPrint scan users with valid credentials access to remote scanning.
  - When configured, credentials must be passed from the AirPrint client to the AltaLink device for authentication. Depending on the Scan Authentication Configuration, the AltaLink device will then authenticate that user name and password locally on the Device User Database or Remotely on the configured Network Authentication Server. Once the credentials are successfully authenticated, then the AirPrint client can initiate remote scans from the AltaLink device.
  - When HTTP Basic authentication is enabled for scanning, the Validation Location can be set to either ‘Validate on the Device’ or ‘Validate on the Network’.
– When HTTP Digest authentication is enabled for scanning, the Validation Location is restricted to only ‘Validate on the Device’.

- **Validation on the Device**: This option enables authentication of users who are configured in the device user database.
- **Validation on the Network**: This option enables authentication of users who are configured on the network authentication server for the printer.

**Note**: The same network authentication configuration is used on the printer for each login method that is configured for Network Authentication.

**LIMITATIONS**

If Scanning Authentication is configured for HTTP Basic Authentication, it is recommended that the AltaLink® device be configured for Force Traffic over Secure Connection (HTTPS), where all HTTP requests are switched to HTTPS.

**CLIENT SUPPORT**

Latest macOS® clients
WORKFLOW

Scan via AirPrint® from a macOS® Client

1. From the macOS client, add a printer from System Preferences > Printers & Scanners.

2. Select the + symbol to add a printer.
3. From the **Add** dialog, select the Bonjour®-discovered AltaLink® device.

4. Select Use: **Secure AirPrint** or **AirPrint**.

5. The AirPrint® device has been added as a Printer/Scanner.
6. Select **Open Scanner** from the Scan tab and the Scanner dialog opens.
7. Load a document to scan in the document handler on the AltaLink® device.

8. Configure the Scan options on the Scanner Dialog on the client (including the location to save the scan, and scan size.)

9. Select **Scan** from the Scanner dialog.

10. The scanned image is displayed in the Scanner dialog.
11. The scanned image can be found on the client in the location specified.
AirPrint® via IPP USB

DESCRIPTION
For AltaLink® devices directly connected to a macOS® client, AirPrint is supported via IPP USB. The Xerox® printer can be discovered, identified and auto-configured as a USB Printer.

REQUIREMENTS
- The macOS client must be connected to the AltaLink device via a USB Type A to USB Type B cable.
- For AirPrint support via IPP USB, the AltaLink device must have the Type B USB port configured for Direct Printing. Note: The default USB Connection Mode is Software Tools.
  - From the AltaLink Web interface, navigate to Properties > Connectivity Setup > USB Settings.
  - To configure USB Connection Mode, select Edit.
  
  ![Web Interface Screenshot]

  – Select Direct Printing via Driver for the USB Connection Mode and Save the change.

  ![Web Interface Screenshot]
– The USB Connection Mode has been set for Direct Printing.

CLIENT SUPPORT

Only supported on macOS® clients (version: 10.11.4 or later).

WORKFLOW

1. Configure the AltaLink® device USB Connection Mode for Direct Printing.
2. Connect the USB Type A to USB Type B cable to the macOS client and the AltaLink device.
3. The macOS client will automatically discover, identify and auto-configure the AltaLink device as an AirPrint® USB Printer.
4. Submit jobs to the AirPrint® USB AltaLink device.
Enhanced Security

DESCRIPTION

The AltaLink® device meets the required AirPrint® v1.6 security requirements for a printer including TLS 1.2 support, mandatory TLS cipher suite support and updated security behaviors around security certificate expiration and key management. The enhanced security supported on the AltaLink device enables seamless integration with high security Apple clients.

Expanded Accounting Workflows with Apple Clients

With the latest iOS and macOS® Apple clients, some Accounting behaviors have changed. On the AltaLink device, IPP Accounting Exceptions can still be used. (See the “Accounting Workflows via IPP Exceptions” section.) However, some new workflows can also be leveraged.

ALTALINK AIRPRINT CAPABILITIES VERSUS CLIENT SUPPORT TABLE

AltaLink devices support two accounting methods: Xerox® Standard Accounting and Network Accounting. Apple client behavior with respect to the AltaLink device configured accounting varies depending on a few factors including Accounting Type enabled, IPP Exceptions enabled, Authentication enabled and Accounting configuration. To help sort out all of the possible scenarios, the table below summarizes the functionality.

<table>
<thead>
<tr>
<th>Apple Client OS</th>
<th>IPP Basic Authentication Enabled</th>
<th>Xerox® Standard Accounting (XSA) Enabled</th>
<th>Network Accounting Enabled</th>
<th>Job Accepted</th>
</tr>
</thead>
<tbody>
<tr>
<td>iOS 10</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes—Always</td>
</tr>
</tbody>
</table>
| iOS 10          | No                              | Yes                                     | No                         | Yes, depending upon the following conditions:  
|                 |                                 |                                         |                            | - If “Account (Account Information)” entered in iOS matches a user name in the AltaLink Device User Database.  
|                 |                                 |                                         |                            | - Or “Account (Account information)” is not entered in iOS and “mobile” user name present in the AltaLink Device User Database.  
|                 |                                 |                                         |                            | - Or Guest Mode Exception enabled at the AltaLink device.  
|                 |                                 |                                         |                            | - Or IPP Exception enabled with “Track IPP jobs with invalid accounting codes” selected at AltaLink device.  |
| iOS 10          | Yes                             | Yes                                     | No                         | Yes, if the iOS entered login credentials match and entry in Device User Database.  |
| iOS 10          | Yes                             | No                                      | No                         | Yes, if the iOS entered login credentials match and entry in Device User Database.  |
| iOS 10          | No                              | No                                      | Yes                        | Yes, depending upon the following conditions:  
|                 |                                 |                                         |                            | - If account is present in Network Accounting Database such that job-accounting-user-id = “mobile” and job-account-id = “Account (Account Information)” entered in OS.  
|                 |                                 |                                         |                            | - Or Guest Mode Exception enabled at the AltaLink device.  
|                 |                                 |                                         |                            | - Or IPP Exception enabled with “Track IPP jobs with invalid accounting codes” selected at the AltaLink device.  |
| iOS 10          | Yes                             | No                                      | Yes                        | Yes, depending upon the following conditions:  
|                 |                                 |                                         |                            | - If account is present in Network Accounting Database such that job-accounting-user-id = iOS entered login credentials username and job-account-id = “Account (Account Information)” entered in iOS.  
|                 |                                 |                                         |                            | - Or Guest Mode Exception enabled at the AltaLink device.  
<p>|                 |                                 |                                         |                            | - Or IPP Exception enabled with “Track IPP jobs with invalid accounting codes” selected at the AltaLink device.  |</p>
<table>
<thead>
<tr>
<th>Apple Client OS</th>
<th>IPP Basic Authentication Enabled</th>
<th>Xerox Standard Accounting (XSA) Enabled</th>
<th>Network Accounting Enabled</th>
<th>Job Accepted</th>
</tr>
</thead>
<tbody>
<tr>
<td>macOS®</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes—Always</td>
</tr>
</tbody>
</table>
|                 | No                               | Yes                                   | No                        | Yes, depending upon the following conditions:  
|                 |                                  |                                       |                           | • If macOS user name matches a user name in the AltaLink® Device User Database.  
|                 |                                  |                                       |                           | • Or Guest Mode Exception enabled at the AltaLink device.  
|                 |                                  |                                       |                           | • Or IPP Exception enabled with “Track IPP jobs with invalid accounting codes” selected at the AltaLink device.  |
| macOS           | Yes                              | No                                    | No                        | No—not fully supported by the client.  |
|                 | Yes                              | Yes                                   | No                        | No—not fully supported by the client.  |
|                 | Yes                              | Yes                                   | Yes                       | No—not fully supported by the client.  |

**Notes:**  
1. Assumes tracking enabled for Job service.  
2. Xerox® Standard Accounting (XSA) and Network Accounting are mutually exclusive; they cannot both be enabled at the same time.  
3. Network Accounting always requires both job-accounting-user-id and job-account-id.  
4. XSA only requires job-accounting-user-id because all XSA accounts have a default job-account-id, although different job-account-id values can be specified.
Directly Configure AltaLink® Device Accounting User IDs to Match Apple Client Values

**DESCRIPTION**

Some iOS and macOS® clients allow entering an accounting code. The iOS client uses “mobile” as the Accounting User ID (if IPP authentication is not being used for the AltaLink device). macOS clients use the logged in user id.

For interoperability with iOS clients, create an accounting user with a user ID equal to “mobile”. For macOS clients, create an accounting user with a user ID equal to the macOS user ID.

**REQUIREMENTS**

- Accounting workflow enabled on the AltaLink device.
- An accounting User Name configured as “mobile” and as the macOS user ID.

**LIMITATIONS**

**Note:** For Xerox® Standard Accounting (XSA), the Account Type will be automatically determined based on the Account ID. If there is no Account ID, then the Default Group Account configured on the AltaLink device is assumed.

**CLIENT SUPPORT**

Latest iOS and maxOS clients.

**WORKFLOW**

**iOS Clients**

1. Configure Accounting on the AltaLink device and add the appropriate accounting users. For iOS clients, an accounting user ID of “mobile” should be created on the AltaLink device.

2. Select a file to print, select the action icon and select **Print**.
3. Select a Printer.

4. Select the Xerox Device.

5. Select Options, and enter an Accounting code if needed for the configured Accounting workflow on the AltaLink® device.
Using Apple® AirPrint® with Xerox® AltaLink® Multifunction Printers

6. Select Print.

7. The job should be tracked against the user ID: “mobile”.

macOS®

1. Configure Accounting on the AltaLink® device and add the appropriate accounting users. For macOS, the accounting user should match the macOS logged in user name.

2. Select a file to print, select Print from the File menu.
3. In the Account ID menu, enable Print with Account ID and enter an Accounting code if needed for the configured Accounting workflow on the AltaLink® device.

4. Select Print.

5. The job should be tracked against the Accounting ID of the logged in user.

Enable IPP Authentication with Accounting

**DESCRIPTION**

When IPP Authentication is used in conjunction with Accounting on the AltaLink® device, updated iOS and macOS® clients utilize the authentication user ID for the accounting user ID. For interoperability with updated clients, create an accounting user with a user ID that aligns with the IPP Authentication Users.
**REQUIREMENTS**
- IPP Authentication enabled on the AltaLink® device. (See the “Print Authentication Support” section.)
- Accounting workflow enabled on the AltaLink device.
- An Accounting User Name configured on the AltaLink device consistent with the IPP Authentication User Name.

**LIMITATIONS**
Note: For Xerox® Standard Accounting (XSA), the Account Type will be automatically determined based on the Account ID. If there is no Account ID, then the Default Group Account is assumed.

**CLIENT SUPPORT**
Latest iOS and macOS clients.

**WORKFLOW**

**iOS Clients**
1. Configure IPP Authentication on the AltaLink device.
2. Configure Accounting on the AltaLink device and add the appropriate accounting users.
3. Select a job to print, select the action icon and select **Print**.
4. Select a Printer. Notice that the printer is locked, which indicates that authentication is required.

5. Enter IPP Authentication Credentials.
6. Select Options, and enter an Accounting code if needed for the configured Accounting workflow on the AltaLink® device.

7. Select Print.

8. The job should be tracked against the user id equal to the IPP authentication user ID.
1. Configure IPP Authentication on the AltaLink® device.
2. Configure Accounting on the AltaLink device and add the appropriate accounting users.
3. Add the Printer on the macOS client.

4. Select a job to print, select **Print** from the **File** menu.
5. In the **Account ID** menu, enable **Print with Account ID** and enter an Accounting code if needed for the configured Accounting workflow on the AltaLink device.

6. Select **Print**.
7. Enter IPP Authentication Credentials when prompted.

8. Select **OK**.

9. The job should be tracked against the user id equal to the IPP authentication user ID.
Existing AirPrint® Capabilities

Printing

DESCRIPTION
Driverless Printing from Apple clients to the AltaLink® device.

REQUIREMENTS

- The AltaLink device must have Allow Printing/Faxing to be initiated From AirPrint Supported Devices enabled.
- The AltaLink device should have a Device Name (which is the Bonjour® name) to easily distinguish the AltaLink device.
  - From the AltaLink Web interface: Properties > Description Page, then configure the Device Name. (Or alternately you can access the Device Name from the AirPrint page: Properties > Connectivity > Setup > AirPrint > Edit.)
  - Optionally assign a Location if desired.
LIMITATIONS

- The AltaLink® device must be discoverable by the Apple client.

CLIENT SUPPORT

iOS clients and macOS® 10.6 or later clients.

WORKFLOW

Print via AirPrint® from iOS Clients (i.e., iPad®, iPhone®, iPod touch®)

1. Select a file to print (such as an email or a photo) from an Apple iOS client.
2. You can initiate printing by selecting the share icon (i.e., the arrow) at the bottom/top of the app.

   It will look similar to this: ⬅️ or this: ⬆️

3. Then tap the Print button or Printer icon to print via AirPrint.

   ![Print icon example]

   ![Share icon example]

   Note: If the Print button does not display in an app, then the app does not support AirPrint at this time.
4. If you are printing for the first time, or if the previously selected printer is not available, you will need to choose the AirPrint® printer by touching Select Printer. You should see a list of one or more AirPrint-enabled printers in your area. Touch the printer to which you would like to print.
5. Configure the printer options:

You should now see configuration options for the printer that you selected in Printer Options. Selecting Options expands the list to allow for adjusting the values. Adjust these as desired for the print job.

There are a few print options (depending on the printer and the file type):

- **Number of copies**: Select the number of copies of the document or image that you want to print.
- **Double-sided printing**: You can choose to print on both sides of the paper if your printer supports two-sided (duplex) printing.
- **Paper selection**: Choose from the supported paper sizes.
- **Page range**: You can select certain pages within a document to print. Page range is only available with certain apps and file types, such as PDFs.
- **Color selection**: When supported, choose an option for the output color (i.e., color or black and white).
- **Finishing**: Choose from the supported finishing options (i.e., staple, fold, punch, etc.). Note: Advanced finishing options are configuration dependent.
- **Account**: Option for adding an accounting code when Accounting is enabled on the device.

6. Tap the Print button to begin printing.
Manage/Cancel Print Jobs from Apple® iOS Device

1. You can check the Apple iOS device print queue by double-tapping the Home button to show the recently used apps.

2. Next, select the Print Center.

3. Review the Print Summary of the client.

Note: The Print Center is only available while printing is in progress.

- The Print Center will display a window with the jobs queued locally on the Apple iOS device.
- To cancel a print job from your Apple device queue, select Cancel Printing.
- When there are no more jobs queued on the Apple device, the Print Center will show no documents waiting.
Print via AirPrint® from a macOS® Client

**Note:** Certain features must first be enabled at the AltaLink® device before installing the AirPrint Printer on the macOS client for these features to be available via the installed printer on the client. This is because some capabilities are only reported by the device if they are enabled and the macOS installed Printer enables some features based on the information reported by the AltaLink device at the time the Printer is added.

These features include:
- AirPrint Scanning
- Accounting
- Fax

If these features are not visible in the macOS AirPrint printer, it could be because they were not first enabled at the printer before the printer was added. The printer should be removed and re-installed on the macOS client to expose these features after being enabled at the printer.

Assuming all desired AltaLink device capabilities are enabled, Add a Printer to the macOS client.

1. From the macOS client, add a printer from **System Preferences > Printers & Scanners**.

2. Select the + symbol to add a printer.
3. From the Add dialog, select the Bonjour®-discovered AltaLink® device.

4. Select Use: Secure AirPrint or AirPrint.

*Note*: An AirPrint® Printer will use IPP/HTTP. A Secure AirPrint Printer uses IPPS/HTTPS.
5. The AltaLink® device has been added as a Printer.

6. Open a file to print on the macOS® client.

7. Select Print from the File menu.

8. Select the Xerox® Printer from the list of printers.

9. Configure the desired printer options (i.e., copies, media, layout, finishing, etc.).

10. Select Print.
Manage/Cancel Print Jobs from Apple® macOS® Client

1. Open the print queue for the Printer that the job was submitted to.
2. Select the icon of the printer in the macOS dock. (Note: The icon appears when the queue has jobs present.)

Or go to Apple menu > System Preferences > Printers & Scanners. Select the printer from the list, then click Open Print Queue.

3. To cancel a print job from your Mac® OS X® printer queue, select the 'x' icon button. To pause a job, select the Pause button.
Outgoing Facsimile (FaxOut via IPP)

**DESCRIPTION**
Some AirPrint® clients can support sending an outgoing facsimile via AirPrint to an AltaLink® device (with embedded fax enabled and configured), which will then send the fax to a final fax destination.

**REQUIREMENTS**
The AltaLink device must have:
- At least one embedded fax line configured for at least the ‘Send’ functionality.
- Enable AirPrint to Allow Printing/Faxing to be initiated From AirPrint Supported Devices. See the “System Administrator Guide” for more details on configuring embedded fax.

**LIMITATIONS**
Not all AirPrint clients support this AirPrint capability at this time.

**CLIENT SUPPORT**
Supported on macOS® clients
**WORKFLOW**

1. Configure Embedded FAX on the AltaLink® device for at least Send functionality.
2. Add a Printer on the macOS® client. From System Preferences > Printers & Scanners > Add a Printer.
3. Select the Bonjour® AltaLink device that is configured with FAX.
4. Configure the Use: Secure AirPrint or AirPrint as desired.
5. The AirPrint® Printer and corresponding Fax devices have been added.

**Note:** macOS® adds a designation “- Fax” to identify the Fax AirPrint Printer during the Printer installation.
6. Submit a Fax Job to the AirPrint® Fax Destination. 

**Note:** The Fax job submission workflow follows the same workflow as printing a file. The Fax AirPrint Printer is chosen for the Printer destination instead of a standard Printer.

7. Select **Print** from the **File** menu.

8. Select the **Xerox® Fax** device for the Printer.
9. Enter the fax destination phone number from the AirPrint® client.

10. Select **Fax** to submit the job.

11. The job is transferred to the AltaLink® device, which in turn completes the fax transmission to the remote fax destination.

**Notes:**
- An IPP FaxOut submission can be sent to one or more fax recipients.
- Supported IPP FaxOut Dialing Characters (for phone numbers including line selection, dialing prefixes and private data delimitation):

<table>
<thead>
<tr>
<th>IPP FaxOut Dialing Characters</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>0–9</td>
<td>DTMF (Dual Tone Multi-Frequency) or PULSE digit to dial</td>
</tr>
<tr>
<td>*</td>
<td>Begin DTMF</td>
</tr>
<tr>
<td>#</td>
<td>End DTMF</td>
</tr>
<tr>
<td>=</td>
<td>* Wait for dial tone</td>
</tr>
<tr>
<td>W</td>
<td>* Wait for dial tone</td>
</tr>
<tr>
<td>:</td>
<td>Switch to DTMF mode</td>
</tr>
<tr>
<td>(</td>
<td>Readability</td>
</tr>
<tr>
<td>)</td>
<td>Readability</td>
</tr>
<tr>
<td>Space</td>
<td>Readability</td>
</tr>
<tr>
<td>I</td>
<td>Start mailbox signaling</td>
</tr>
<tr>
<td>,</td>
<td>* Pause character (default is 3-second pause time)</td>
</tr>
<tr>
<td>P</td>
<td>* Pause character (default is 3-second pause time)</td>
</tr>
<tr>
<td>/</td>
<td>Private data delimiter</td>
</tr>
<tr>
<td>&lt;1&gt;</td>
<td>Select line 1</td>
</tr>
<tr>
<td>&lt;2&gt;</td>
<td>Select line 2</td>
</tr>
</tbody>
</table>
Accounting Workflows via IPP Exceptions

**DESCRIPTION**
This is a way to work around current AirPrint®/IPP accounting workflow limitations.

Some AirPrint clients do not provide a way to supply accounting codes and some AirPrint clients send jobs with accounting codes that cannot be altered by the job submitter. When accounting with tracking/validation is enabled on the AltaLink® device, accounting codes are required to successfully print and track jobs. Jobs without accounting codes or with invalid accounting codes will be rejected.

The AltaLink device IPP accounting exception allows AirPrint/IPP clients to track their jobs against a specific IPP exception code. This allows jobs to successfully print and be tracked when accounting is enabled and configured for tracking/validation.

**Note:** This exception is available for both Xerox® Standard Accounting (XSA) and Network Accounting.

**REQUIREMENTS**
The AltaLink device must have an accounting method enabled (XSA or Network Accounting) and tracking enabled.

**CLIENT SUPPORT**
Exceptions can be used with any AirPrint/IPP client.

**XSA WORKFLOW**
1. Enable XSA. See the "System Administrator Guide" for more details.
2. Configure XSA Validation Policies and Print Job Exceptions.
   a) Set the printer to validate the accounting codes for all jobs except those that originated from IPP/AirPrint.
   b) On the AltaLink Web page, click Properties > Login/Permissions/Accounting > Accounting Methods.
   c) Under Action, for Validation Policies/Print Job Exceptions, click Edit.
3. For Validate Accounting Code, select Yes with Exceptions.
4. To allow IPP print jobs, for Exceptions for Jobs Not Containing an Accounting Code, select IPP Exception Mode. Select an option.
   a) **Track IPP jobs with invalid accounting codes against the IPP Exception User and Account IDs:** Use this option to allow print jobs with invalid accounting codes from IPP sources. This configuration prevents rejection of jobs from IPP clients such as AirPrint.

   IPP Exception User and Account IDs:
   - User ID:IPPExceptionUserId
   - Account ID:IPPExceptionAcctId

   b) **Reject IPP jobs with invalid accounting codes:** Use this option to reject print jobs with invalid accounting codes.
Note: Apple® iOS clients send an unalterable accounting user ID value of “mobile”. To allow jobs from these clients, select Track IPP jobs with invalid accounting codes against the IPP Exception User and Account IDs.

5. Click Save.
Network Accounting Workflow

1. Enable Network Accounting. See the "System Administrator Guide" for more details.

2. Configure Network Accounting Validation Policies and Print Job Exceptions.
   a) Set the printer to validate the accounting codes for all jobs except those that originated from IPP/AirPrint®.
   b) In the AltaLink® Web page, click Properties > Login/Permissions/Accounting > Accounting Methods.
   c) On the Accounting Methods page, for Action, next to Validation Policies/Print Job Exceptions, click Edit.
   d) For Enablement, select Enabled.
   e) For Validate Accounting Code, select Yes with Exceptions.

3. To allow IPP print jobs, for Exceptions for Jobs Not Containing an Accounting Code, select IPP Exception Mode. Select an option.
   a) Track IPP jobs with invalid accounting codes against the IPP Exception User and Account IDs: Use this option to allow print jobs with invalid accounting codes from IPP sources. This configuration prevents rejection of jobs from IPP clients such as AirPrint.
      IPP Exception User and Account IDs:
      User ID: IPPExceptionUserId
      Account ID: IP Address or Host of the IPP client that submitted the job.
   b) Reject IPP jobs with invalid accounting codes: Use this option to reject print jobs with invalid accounting codes.

   Note: Apple® iOS clients send an unalterable accounting user ID value of "mobile". To allow jobs from these clients, select Track IPP jobs with invalid accounting codes against the IPP Exception User and Account IDs.

4. Click Save.
Print Authentication Support

**DESCRIPTION**

IPP can be configured on the AltaLink® device to require authentication (through HTTP Basic authentication), providing a way for AirPrint® clients to use the AltaLink device configured authentication.

**REQUIREMENTS**

IPP can be configured on the AltaLink device to require IPP clients (which includes AirPrint clients) to use authentication before submitting a job. When configured, credentials must be passed from the AirPrint client to the AltaLink device for authentication. Depending on the AltaLink device IPP Authentication Configuration, the device will then authenticate that user name and password locally on the Device User Database or Remotely on the configured Network Authentication Server. Once the credentials are successfully authenticated, then the AirPrint/IPP client can submit the job to the AltaLink device.

By default, Requiring Authentication for IPP is disabled.

To enable IPP to Require Authentication using HTTP Basic Authentication:

1. On the AltaLink Web page, click **Properties > Connectivity > Setup**.
2. For Protocol, next to IPP, click **Edit**. IPP should be enabled by default.
3. To enable IPP authentication, for Require Authentication, select **HTTP Basic**.
4. When HTTP basic authentication is enabled, for Validation Location, select an option.
   - **Validation on the Device**: This option enables IPP authentication of users that are configured in the device user database.

5. Configure users in the Device User Database.

6. Configure the network authentication server.

   **Note**: The same network authentication configuration is used on the printer for each login method that is configured for Network Authentication.

   **Note**: If IPP Authentication is configured and two or more authentication servers are configured, then the IPP Authentication Policy window displays. The IPP Authentication Policy is used to determine which server to use for IPP Authentication.
LIMITATIONS

IPP Authentication is limited to only HTTP Basic Authentication. It is recommended that the AltaLink® device be configured for Force Traffic over Secure Connection (HTTPS), where all HTTP requests are switched to HTTPS.

CLIENT SUPPORT

iOS and macOS® clients

WORKFLOW

iOS Clients
1. Configure IPP Authentication on the AltaLink device.
2. Print a file from iOS.
3. Select the share icon.
4. Then tap the **Print** button or Printer icon to print via AirPrint®.

5. Choose the AirPrint printer by touching **Select Printer**.

6. Select the **AltaLink® device**. Notice that there is a lock icon for the printer.
7. Enter the IPP Authentication Credentials for the device.

8. Configure the Printer Options.

9. Tap **Print** to begin printing.
macOS® Clients

1. Configure IPP Authentication on the AltaLink® device.
2. Add a Printer to the macOS client.
3. From System Preferences > Printers & Scanners > Add a Printer.
4. Select the AltaLink device with IPP Authentication enabled.
5. Configure the Use: Secure AirPrint or AirPrint as desired.
6. Submit a Print Job to the AltaLink® device.
7. Select Print from the File menu.
8. Configure the Print Options and submit the job by selecting Print.

9. The job will be Held for Authentication.
10. When prompted, enter the IPP Authentication Credentials for the Device.

11. When the credentials are validated, the job will resume.
Identify Printer Capability

DESCRIPTION
The AltaLink® device can be identified from remote AirPrint® clients by:
1. Making a sound
2. Flashing a light
3. And/or displaying a message at the AltaLink Device Local Interface
This could be used to help find a particular AltaLink device if a client is in an area where multiple devices are supported.

REQUIREMENTS
- By default, the IPP Identify Printer functionality is enabled.
- To configure the IPP Identify Printer functionality:
  1. On the AltaLink Device Web page, click Properties > Connectivity > Setup.
  2. For Protocol, next to IPP, click Edit. IPP should be enabled by default.
  3. To configure Identify Printer, select an option.
     - On: This option enables an IPP client to request the printer to identify itself through a graphic or sound.
     - Off: This option revokes the ability of an IPP client to request the printer to identify itself through a graphic or sound.
  4. Click Save.

LIMITATIONS
- Limited client support with older clients.
- Limited support within Apps.

CLIENT SUPPORT
- iOS 10 and later and macOS®
**WORKFLOW**

**iOS Clients**

An iOS client is attempting to submit an AirPrint® job to a local AltaLink® device. The user has selected a printer, but isn’t sure which of the several output devices is actually the printer they have chosen. The iOS client allows users to remotely identify the printer selected.

1. Print a file from iOS.
2. Select the share icon.
3. Tap the Print button or Printer icon to print via AirPrint.
4. Choose the AirPrint printer by touching Select Printer.
5. Select the information icon next to the AltaLink® device.

6. From the Printer Info page, select Identify Printer to submit an Identify Printer request to the AltaLink device.

7. The AltaLink device sounds the identify printer tone (if tones are enabled), raises a Local User Interface message and flashes a light to allow the user to identify the AltaLink device.

8. After identifying the printer, the user can continue with the print job submission.
macOS® Clients

The macOS client allows users to remotely identify an AirPrint® printer selected during printer installation.

1. Add a Printer to the macOS client.
2. From System Preferences > Printers & Scanners > Add a Printer.
3. Select the AltaLink device.
4. Configure Use: Secure AirPrint or AirPrint as desired.

5. Select Options & Supplies from the printer details.
6. From the **General** tab, select **Find Printer** to submit an Identify Printer request to the AltaLink® device.

7. The AltaLink device sounds the identify printer tone (if tones are enabled), raises a Local User Interface message and flashes a light to allow the user to identify the device.
Secure AirPrint®

DESCRIPTION
Secure AirPrint is AirPrint communication over IPPS (Secure IPP) via HTTPS. By default, the AltaLink® device can support both non-secured AirPrint (over IPP) and Secure AirPrint (over IPPS). The AltaLink device can be configured to only support Secure AirPrint by enabling the HTTP configuration item called "Force Traffic over Secure Connection (HTTPS)".

REQUIREMENTS
- When “Force Traffic over Secure Connection (HTTPS)” is enabled, the AltaLink device will support AirPrint only over IPPS (only Secure AirPrint).
- When “Force Traffic over Secure Connection (HTTPS)” is disabled, the AltaLink device will support AirPrint over either IPP (AirPrint) or IPPS (Secure AirPrint).

CONFIGURATION
1. On the AltaLink Web page, click Properties > Connectivity > Setup.
2. For Protocol, next to HTTP, click Edit.
3. To encrypt HTTP communication, for Force Traffic over Secure Connection (HTTPS), select Yes. When Force Traffic over Secure Connection (HTTPS) is enabled, all Web pages contain https:// in the URL and AirPrint is limited to only Secure AirPrint connections.
4. For the Choose Device Certificate menu, for HTTPS, select the Device Certificate.
5. To view the selected certificate details, or save the certificate to your computer, click View/Save.
6. If you select Xerox® Default Device Certificate, you can install the Generic Xerox® Trusted CA Certificate in your Web browser. Installing the Generic Xerox® Trusted CA Certificate ensures that your browser trusts the printer. To download the certificate, click Download the Generic Xerox® Trusted CA Certificate.
7. Change the Secure HTTP Port Number as needed.
8. Click Save.

Note: Enabling “Force Traffic over Secure Connection (HTTPS)” switches all HTTP requests to the AltaLink device to HTTPS, not just those related to AirPrint.
WORKFLOW

iOS Clients

iOS clients use IPPS (i.e., Secure AirPrint®) by default regardless of the configuration of the AltaLink® device.

macOS® Clients

- When adding a printer from a macOS client, the Use: option will be limited based on the AltaLink device’s configuration of “Force Traffic over Secure Connection (HTTPS)”.
- When the AltaLink device is configured with “Force Traffic over Secure Connection (HTTPS)” disabled, then from a macOS client, Use: can optionally be configured for Secure AirPrint or AirPrint.

- When the AltaLink device is configured with “Force Traffic over Secure Connection (HTTPS)” enabled, then from a macOS client, the Use: can only be configured for Secure AirPrint.
Troubleshooting

What if I can’t find the AirPrint® settings on my AltaLink® device?
Please refer to the "AirPrint® Feature Installation Key" section of this document.

What if I can’t find an AirPrint printer from my Apple device?
I can’t find my AltaLink device when I try to print from my Apple device or I get a message: "No AirPrint Printers Found." What’s going on?
1. First try to confirm that AirPrint is enabled on the AltaLink device. See “How is AirPrint enabled and configured on the AltaLink device?”
2. Next, AirPrint requires that devices are discoverable via the Apple® proprietary protocol, Bonjour®. In some networks, this traffic is not allowed to be passed across subnets. In this case, a device will only be discoverable if the Apple device and the AltaLink device are on the same subnet or if other cross-subnet solutions for multicast DNS are implemented.
3. Make sure that your Apple device is connected to the same subnet as the AltaLink device.
4. From the Apple device, tap on the Settings icon.
5. Navigate and tap on Wi-Fi networks.
6. Confirm the Apple device is connected to the correct Wi-Fi® network (checkmark next to network name).

7. Check the IP address of the Apple device by selecting the More Details Arrow to the right of the network.

8. Confirm that the IP address of the Apple device is for the correct network.
9. Make sure that the AltaLink® device is connected to the correct network.

10. Print a Configuration Report to confirm the IPv4 address of the device. (See the Connectivity Physical Connections, and Connectivity Protocols, TCP/IPv4 sections of the report) or

11. Check the AltaLink Device App from the Local User Interface. Select About to view the IPv4 address.

12. Confirm that the IP address of the AltaLink device is for the correct network.

13. If both devices are on the same subnet and your device is still not being discovered, check with your IT administrator to ensure that multicast DNS (mDNS) traffic is not being filtered on your network.

14. Finally, if you still can't find the device, restart the Apple device and the AltaLink device.

**Where are my AirPrint® jobs on the AltaLink device’s queue?**

When an Apple® iOS device appears to submit consecutive print jobs to an AirPrint-enabled AltaLink device, it only sends the first job and queues the subsequent jobs at the Apple device until it gets notification that the prior print job completed. After one job completes, the next job is released from the Apple device. This behavior is driven by Apple’s AirPrint implementation.

For example:

- On an Apple iOS device, submit five consecutive jobs to an AltaLink device. (See Printing—Print via AirPrint from iOS Clients.)
- Observe the jobs in the Apple device’s print queue. (See Manage/Cancel Print Jobs from Apple® iOS Device.)
Using Apple® AirPrint® with Xerox® AltaLink® Multifunction Printers

Notice the status of each of the five jobs by touching each job in the list. The first job has a status of Printing, all subsequent jobs are Waiting.

<table>
<thead>
<tr>
<th>Job #</th>
<th>Status</th>
<th>Document</th>
<th>Printer</th>
<th>Copies</th>
<th>Options</th>
<th>Sent</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Printing</td>
<td>Photo</td>
<td>Xerox device</td>
<td>1</td>
<td>Single-sided, Letter</td>
<td>Today, 1:28 PM</td>
<td>Waiting</td>
</tr>
<tr>
<td>2</td>
<td>Waiting</td>
<td>Mixed Page Size Region 4x4 02.pdf</td>
<td>Xerox device</td>
<td>1</td>
<td>Double-sided, Letter</td>
<td>Today, 1:28 PM</td>
<td>Waiting</td>
</tr>
<tr>
<td>3</td>
<td>Waiting</td>
<td>AirPrint test</td>
<td>Xerox device</td>
<td>1</td>
<td>Single-sided, Letter</td>
<td>Today, 1:29 PM</td>
<td>Waiting</td>
</tr>
</tbody>
</table>

Cancel Printing
On the AltaLink® device, select the Jobs App. Select the All Active Jobs print queue and notice that only the first job from that Apple® iOS device is visible. It is the only job that has been sent to the AltaLink device from that Apple iOS device. Once this job completes, the next job queued on the Apple iOS device will be sent to the AltaLink device.
I discovered the Xerox® AltaLink® device from my Apple device. Why am I having trouble with my job completing?

Please try disconnecting your Apple device from any cellular data networks (by enabling airplane mode and re-enabling Wi-Fi®) and then try submitting the job again.

I submitted a print job from my Apple device to an AltaLink device via AirPrint®, but I am getting a message on my Apple device that says “Check the printer for errors.” What is going on?

AirPrint provides generic error message handling. The AirPrint message, “Check the printer for errors” can correspond to multiple kinds of alerts or faults on the device and often it will not impact the ability of the AltaLink device to print. Select Continue and check the printer for your output. If your job has not been completed, check the AltaLink device for errors.

I submitted a print job from my Apple device to a Xerox® AltaLink device via AirPrint, but I am getting a message on my Apple device that says “Printer out of paper.” My job still prints. Why is this happening?

AirPrint provides generic error message handling. The AirPrint message, “Printer out of paper” can correspond to multiple kinds of paper alerts on the device and often it will not impact the ability of the AltaLink device to print. The message may be alerting you that one tray is out of paper but other trays may be available to complete the job. Select Continue / Cancel and check the printer for your output. If your job has not been completed, check the AltaLink device for errors.

I only see a few printer configuration features in the AirPrint dialog. Why?

Currently, Apple is only providing a limited subset of printer configuration features from within iOS. As the AirPrint feature evolves, you can expect to see additional device settings and capabilities within the print dialogs. For the time being, only a small number of printer configurations are available.

What are some possible solutions for Enterprise Networks that span multiple subnets but still want to leverage AirPrint capabilities?

Please refer to “Xerox® AltaLink® Multifunction Printers Deliver Apple® AirPrint® to the Enterprise” at this link: www.office.xerox.com/latest/XOGWP-17.PDF.
AirPrint® Feature Installation Key

A Feature Installation Key (FIK) may be needed if AirPrint is not available on your AltaLink® device. There is no cost for the AirPrint FIK. Please refer to “Enabling Apple® AirPrint® with Your Xerox® AltaLink® Multifunction Printer” for more information on obtaining the AltaLink AirPrint FIK. FIK availability is pending Apple AirPrint Certification.

FIKs can be installed by the System Administrator from the local control panel (Device > Tools > Device Settings > General > Feature Installation) or from the Embedded Web Server (Properties > General Setup > Feature Installation). See the System Administrator Guide for more information on Installing a FIK.

Feature Installation Key

INSTALLING A SOFTWARE FEATURE AT THE CONTROL PANEL

1. At the control panel touchscreen, touch Device, then touch Tools.
2. Touch Device Settings > General > Feature Installation.
3. Touch Enter Feature Installation Key, then type the key.
4. Touch OK.

INSTALLING A SOFTWARE FEATURE IN EMBEDDED WEB SERVER

1. In the Embedded Web Server, click Properties > General Setup.
2. Click Feature Installation.
3. For Feature Installation Key Entry, click Enter Installation Key.
4. Type the key.
5. Click Apply.